Spring 2024 registration failure for Undergraduates
Incident Report for Emerson College
Resolved
The final days of Spring 2024 registration were completed without issue.
Posted Nov 17, 2023 - 12:39 EST
Update
Today's 7am registration for undergraduate students with 60–75.99 credits completed was conducted successfully. This incident will remain opened and monitored until end of registration on Friday, November 17th.
Posted Nov 14, 2023 - 07:14 EST
Update
Today's 7am registration for students with 76–91.99 credits completed was conducted successfully. This incident will remain opened and monitored until end of registration on Friday, November 17th.
Posted Nov 13, 2023 - 07:14 EST
Monitoring
We are happy to announce that this morning’s retry for Undergraduates with 92+ credits was conducted successfully. The parameters that were fixed in the previous status update prevented the “an error has occurred during the processing of your registration” errors. We saw the completion of hundreds of successful registrations this morning.

Therefore, we will continue with the updated Registration schedule:

Registration Times
76-91.99 Credits Completed: Monday, November 13th at 7:00 a.m. EST
60-75.99 Credits Completed: Tuesday, November 14th at 7:00 a.m. EST
44-59.99 Credits Completed: Wednesday, November 15th at 7:00 a.m. EST
28-43.99 Credits Completed: Thursday, November 16th at 7:00 a.m. EST
12-27.99 Credits Completed: Friday, November 17th at 7:00 a.m. EST
0-11.99 Credits Completed: Friday, November 17th at 7:30 a.m. EST

This incident will remain open until the end of the Registration period, and any additional updates will be posted here as well.
Posted Nov 09, 2023 - 07:33 EST
Update
Please note this important update on the Course Registration system.

Our IT Team has been working very hard to resolve the issues that occurred on Monday and Tuesday. They just notified us they have identified and fixed several issues and they believe that the system will now operate as intended. If any additional problems do occur, we will be sure to notify all students immediately.

In order to make sure you can register in a timely manner, we will open registration tomorrow, Thursday November 9th for Undergraduates with 92+ credits completed. Assuming all registration functions as intended, we will notify students and continue with registration times as follows:

Registration Times
92+ Credits Completed: Thursday, November 9th at 7:00 a.m. EST
76-91.99 Credits Completed: Monday, November 13th at 7:00 a.m. EST
60-75.99 Credits Completed: Tuesday, November 14th at 7:00 a.m. EST
44-59.99 Credits Completed: Wednesday, November 15th at 7:00 a.m. EST
28-43.99 Credits Completed: Thursday, November 16th at 7:00 a.m. EST
12-27.99 Credits Completed: Friday, November 17th at 7:00 a.m. EST
0-11.99 Credits Completed: Friday, November 17th at 7:30 a.m. EST

All currently enrolled Speech@Emerson students: Tuesday, November 14th at 1:00 p.m. EST

Graduate students, excluding Speech@Emerson, have the ability to adjust their registration right now.

We sincerely apologize for the inconvenience and stress that this technical issue has caused, and we thank you for your patience, especially during a particularly busy and difficult time of the semester.

Please continue to check your Emerson email for any additional updates. We will be in touch with additional information tomorrow to confirm the status of registration.

If you have any technical issues with the registration system, please contact our IT team at helpdesk@emerson.edu.

If you have any questions about registration, please email registrar@emerson.edu.
Posted Nov 08, 2023 - 16:56 EST
Update
Yesterday evening, several parameters were updated to Banner Registration:
• Doubled our connections between the registration application to the student database system, which we observed were timing out during the failed registrations of the past two days.
• Increased session timeout significantly

We believe these updates will resolve the registration issues. We will provide an update later today with next steps.
Posted Nov 08, 2023 - 12:24 EST
Update
Throughout the day today we created an identical copy of the registration system to ensure the tests we run will be accurate and precise. This evening, we will be conducting a simulation of registration in an attempt to reproduce the error students saw. We will then work through recommended troubleshooting steps provided by Ellucian and re-run our simulations until we do not see these errors. Additionally, we have contracted Ellucian professional services who will review our registration configuration tomorrow.

As a reminder, currently all registration windows are postponed while we resolve this issue. Once resolved, we will publish a revised schedule.

Thank you again for your patience and understanding while we work through these unexpected problems!
Posted Nov 07, 2023 - 16:46 EST
Update
Our team continues their work to identify a root cause. Efforts are currently focused on cloning this registration to our test system and running a simulation to reproduce the error. We will provide a more substantive update later this evening.
Posted Nov 07, 2023 - 15:17 EST
Update
Undergraduate Registration on Hold

Registration is on hold until we validate a reliable fix for this error. We are diligently focused on identifying the root cause and we are re-engaging with Ellucian. As we identify possible root causes, we will continue to use our test environment to simulate registration and attempt to reproduce the error in that environment.

Resolving this issue is our highest priority. We sincerely apologize for the disruption this is causing.

We will provide technical updates here throughout the day. The Registrar will email students when a revised registration schedule is available.
Posted Nov 07, 2023 - 10:25 EST
Update
We will provide technical updates here throughout the day. The Registrar will email students when a revised registration schedule is available.
Posted Nov 07, 2023 - 10:24 EST
Investigating
Spring registration began on November 2nd and 3rd for Graduate students without errors. Undergraduate registration opened on November 6th at 7am, and at first, some students were able to register for classes. Yet, within a few minutes, Banner, the system used for registering for classes, failed, as many students reported receiving an error that read “an error has occurred during the processing of your registration." on some or all of their registration selections.

In response, the Registrar closed registration at 7:15am and our database team immediately reviewed system events to identify the cause of the error. Additionally, we requested support from Ellucian, the company that maintains Banner.

The database team performed several remedial actions Monday morning, in coordination with Ellucian:
• Cleanup of temporary registration data, which included incomplete/abandoned course registrations to prevent database locking contention.
• Performed a full restart of the registration application and related systems.
• Recreated database indexes in order to optimize speed.
• Removed courses that were in students' "Plan Ahead" that no longer exist.

At 7am on November 7th, the experience was the same as the previous day, in which some students successfully registered for courses while others encountered the error, halting registration. The Registrar closed registration again and sent an email to students at 7:04 am.
Posted Nov 07, 2023 - 10:24 EST
This incident affected: Banner - Student Registration.