my.emerson.edu technical issues

Incident Report for Emerson College

Resolved

The issue has been resolved.
Posted Jul 07, 2026 - 13:37 EDT

Monitoring

Some users have reported that visiting my.emerson.edu or m.emerson.edu has not worked, resulting in a 500 error. We have identified a workaround:
1. Open Google Chrome and click the three dots in the top right and click New Incognito Window.
2. Go to my.emerson.edu or m.emerson.edu. This will work.

Alternatively, clear your browser cache. We expect that this will clear up for all users in the coming day.

If you are registering for classes, simply go directly to register.emerson.edu.
Posted Jul 07, 2026 - 10:31 EDT
This incident affected: Banner - Student Registration and Emerson Mobile App.