Degree Works Outage
Incident Report for Emerson College
Resolved
This incident has been resolved.
Posted Sep 24, 2023 - 18:51 EDT
Investigating
We have confirmed reports that users are receiving an Error 500 when visiting Degree Works, No other systems, including Banner, appear to be impacted. We have escalated to our specialists who are investigating the issue.
Posted Sep 24, 2023 - 18:13 EDT
This incident affected: Degree Works.