Workday Outage - 3/17/2025

Incident Report for Emerson College

Resolved

Users continue to have success logging in.
Posted Mar 17, 2025 - 16:37 EDT

Monitoring

Users are reporting that they are able to get into Workday again. We are waiting for Workday to provide an all-clear.
Posted Mar 17, 2025 - 15:39 EDT

Investigating

When logging into Workday, users are currently encountering a "Workday is currently unavailable" error. This appears to be an issue impacting Workday customers broadly.

We will send an update as soon as we receive new information. Thank you for your patience in the meanwhile.
Posted Mar 17, 2025 - 15:01 EDT
This incident affected: Workday.